Wenn die Summenformel zu lang wird

[MS-Excel – alle Versionen]

Manchmal ist es  bei umfangreichen Arbeitsmappen notwendig aus vielen Tabellen die Summen bilden zu müssen. Dabei gibt es allerdings das Handicap, dass die Anzahl der Zeichen zur Formeleingabe in der Zelle begrenzt ist. Wird die Grenze überschritten, erscheint die Meldung, dass die Formel zu lang ist.

Wenn Sie in der Arbeitsmappe immer Werte aus der gleichen Zelle der Tabellenblätter verrechnen müssen, so können Sie die Summenformel so erstellen, dass das Limit gar nicht erst überschritten wird.

Zum Eintragen von Formeln besteht bei den Versionen bis 2003 ein Limit von 1.024 Zeichen. Bei den Versionen ab 2007 stehen Ihnen „nur“ bis zu 8.192 Zeichen zur Verfügung. Auch wenn es sich nach „viel“ anhört, ist bei umfangreichen Projekten die Grenze schnell überschritten.

Wenn auf einem Tabellenblatt viele Zahlen summiert werden sollen, benutzen viele dazu nicht mehr die [+]-Taste, sondern die Summenfunktion in Verbindung mit einem marklierten Bereich:

  • =SUMME(A1:A100)

.

Dieses Prinzip mit dem Bereich können Sie auch auf die Tabellenblätter übertragen. Sie müssen dann nur noch gewährleisten, dass die Tabellen auf den einzelnen Blättern denselben Aufbau haben. Das heißt, die zu summierenden Zellen müssen alle denselben Bezug haben.

Nehmen wir an, Sie wollen immer die gleiche Zelle, beispielsweise in „A1“, aus „Tabelle 1“ bis „Tabelle 100“ zusammenrechnen und auf einen Extrablatt anzeigen lassen. So ist dann folgende Formaleingabe möglich:

  • =SUMME(‚Tabelle1:Tabelle100‘!A1)

.

Haben Sie die Tabellenblätter mit anderen Namen versehen, nehmen Sie für den „Tabellenblätterbereich“ einfach den Namen des ersten und des letzten Tabellenblattes.

Nehmen wir an, Sie haben den Tabellenblättern die Bezeichnungen in der Form „Anton“, „Berta“, „Cäsar“ bis „Zacharias“ gegeben, dann sollte die Funktion so aussehen:

  • =SUMME(‚Anton:Zacharias‘!A1)

.

HINWEIS: Sie müssen dabei noch darauf achten, dass das Tabellenblatt mit der oben genannten Summenformel immer vor oder hinter den Tabellenblättern steht, die Sie zusammenrechnen wollen. Sie erhalten sonst die Fehlermeldung, dass ein Zirkelbezug besteht.

.

Advertisements

Kommentar-Einträge mit Werbecharakter (sogenannte SPAM) werde ich ohne Nachfrage löschen! - Comment-entries of an advertising nature (so-called SPAM) I will delete without asking!

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s