Zeitangaben im Viertelstundentakt runden

[MS-Excel – alle Versionen]

Wenn Sie Zeitangaben (HH:mm) auf Viertelstunden auf- oder abrunden wollen, so müssen Sie eine Formel entwickeln, die die RUNDEN-Funktion enthält. Doch damit alleine ist es noch nicht getan.

Man muss jetzt noch wissen, dass die Tabellekalkulation alle Zeitwert auf einen Tag bezieht. Das heißt, beispielsweise sind 8 Stunden ein Drittel und 12 Stunden die Hälfte eines Tages. Das ist auch ein Grund, warum die Anwendung den Zahlenwert 0,33 und 0,5 anzeigt, wenn Sie das Zahlenformat „Standard“ einstellen. Also muss noch ein Umrechnungsfaktor in die Formel eingebaut werden.

Unter HH:07:30 soll abgerundet und über HH:07:30 aufgerundet werden. So lautet das Ziel.

Um jetzt die viertelstündige Auf- und Abrundung zu erreichen müssen, wir wissen, das es 96 Viertelstunden pro Tag (24 h * 4) gibt. Wenn wir davon ausgehen, dass in der Zelle „A1“ die Zeitangabe steht, lautet die Gleichung erstmal „=A1*96“.

Jetzt führen wir noch die Rundung durch, um bei dem Ergebnis eine Kommazahl zu vermeiden. Dann lautet die Gleichung „=RUNDEN(A1*96;0)“. Die Null in der Klammer nach dem Semikolon gibt an, dass auf Null Stellen hinter dem Komma gerundet werden soll.

Somit haben wir die Anzahl der Viertelstunden zu dem Zeitwert errechnet und müssen diese Angabe wieder in eine Zeitangabe umrechnen. Dazu teilen wir das Ganze durch die Zahl 96. Dadurch ändert sich die Formeleingabe zu „=RUNDEN(A1*96;0)/96“ und das ist die Gleichung, die Sie in der Ergebniszelle eingeben müssen.

Sollte dabei trotzdem ein dezimaler Wert angezeigt werden, müssen Sie mit Hilfe der Tastenkombination [Strg] und [1] die Zellenformatierung aufrufen und im Register „Zahlen„, die Kategorie „Uhrzeit“ oder „Zeit“ wählen und das gewünschte Zeitformat (HH:mm) markieren. Mit „OK“ wird die Umformatierung ausgeführt.

.

Advertisements

Kommentar-Einträge mit Werbecharakter (sogenannte SPAM) werde ich ohne Nachfrage löschen! - Comment-entries of an advertising nature (so-called SPAM) I will delete without asking!

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s